
 

 

WorkPower Build 
 

This guide walks the reader through building a Virtual Instrument, VI, using LabVIEW. This VI 

displays graphs of Work and Power for selected Force and Distance values. 

 

This document and the VI are the property of Education Service Center, Region XIII. Please 

direct any comments and questions about the use or distribution of this document to: 

 

Joules Webb 

Education Service Center, Region 20 

julianne.webb@esc20.net 

(210) 370-5497 

 

Thank you for reviewing this document and providing any feedback.  

 

Warm regards, 
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Building WorkPower VI 
 

This guide walks the reader through building a Virtual Instrument, VI, using LabVIEW. This VI 

displays graphs of Work and Power for selected Force and Distance values using the formulae 

FdW and
t

W
P . 

 

The Work graph will be a horizontal line showing that work is constant when force and distance 

are held constant, while Power is Work/time.  

 

1) Create a new VI by selecting File»New VI or pressing <Ctrl-N> 

 

The <Ctrl> key in keyboard shortcuts corresponds to the (Mac OS) <Command> key or (Linux) 

<Alt> key. 

 

Create the Front Panel 

 

2) Add a numeric control to the front panel 

a. Right-click on the front panel to open the Controls palette 

b. Tack the Controls palette down by clicking the thumb tack in the upper right 

hand corner of the palette 

c. Select Knob from Express»Numeric Controls 

d. Click on the front panel to place the control 

 

 

Figure 1. The Controls palette 



 

 

 

3) Add a digital display for the knob 

a. Right-click on the knob to open the context menu 

b. Select Visible Items»Digital Display 

 

 
 

4) Make a copy of the knob 

a. Hover the mouse over the control until the cursor becomes an arrow (This is the 

position/size/select tool.) 

b. Click on the control to select it 

c. Select Edit»Copy or press <Ctrl-C> 

d. Click on the front panel and select Edit»Paste or press <Ctrl-V> 

5) Name the controls 

a. Triple-click the label of each control to highlight the text 

b. Name the controls “Force” and “Distance” 

 

Next, you will add XY Graphs to the front panel. These indicators will be used to display the 

graphs of Work and Power with respect to time. 

 

6) Add an XY Graph to the front panel 

a. Click on the double arrows at the bottom of the Controls palette 

b. Select XY Graph from Modern»Graph 

 

Be sure to use the XY Graph from the Modern subpalette. The Express XY Graph in the 

Express»Graph Indicators palette is not the same indicator. 

 

c. Click on the front panel to place the graph 

d. Change the label of the graph from “XY Graph” to “Work” 

7) Add a second XY Graph to the front panel 

a. Change the label of the graph from “XY Graph” to “Power” 

b. If necessary, resize the front panel to accommodate the second XY Graph 

8) Save your VI 

a. Select File»Save or press <Ctrl-S> 

b. Call the VI myWorkPower 

 



 

 

 

Figure 2. The beginnings of the front panel 

 

You will add code to the VI to use these values to calculate Work and Power. The block diagram 

of a VI displays the code that executes when the VI is run. So far, the block diagram has only 

four items on it – two orange icons for the Knobs and two brown icons for the graphs. 

 

9) Select Window»Show Block Diagram or press <Ctrl-E> to view the block diagram 

10) Arrange the icons as shown below 

 

 

Figure 3. The beginnings of the block diagram 

 

Create a Graph for Work Done over Time 

 

Work is the product of force and distance. Multiplication is easy to add to the VI.  

 

11) Add a Multiply VI to the block diagram 

a. Right-click on the block diagram to open the Functions palette 

b. Tack the Functions palette down by clicking the thumb tack in the upper left 

corner of the palette 



 

 

c. Click on the double arrows at the bottom of the Functions palette to expand the 

menu 

d. Select Programming»Numeric»Multiply 

e. Click on the block diagram to place the VI 

12) Connect Force and Distance to the Multiply VI 

a. Wire the terminal of Force to the first input of the Multiply VI 

b. Wire the terminal of Distance to the second input of the Multiply VI 

 

To wire the components together, hover the mouse over the terminal of the array until the wiring 

tool appears. Then, hold down the left mouse button and drag the cursor to the destination 

terminal. When the terminal appears, release the mouse button to connect the wire. 

 

 

Figure 4. FdW  

 

The output of the Multiply VI will have the amount of work for the given force and distance. 

You will use this value to create a graph of work and power. 

 

LabVIEW has built-in VIs for evaluating a function entered as text. You can use these VIs to 

evaluate functions for given values of x, or t. What functions are you evaluating? Well, there are 

two. The function you will use first is for Work, FdW . This function is constant with respect 

to time. Once values for force and distance are selected, work is simply their product.  

 

The other function, Power, is not constant. From the formula, 
t

W
P , it is clear that as the 

amount of time changes, the power will change as well. You will use this function when you set 

up the VI to graph Power over time. 

 

Before adding the VIs to evaluate your functions, you will create a string of text to represent the 

formulae. LabVIEW has tools for turning numeric data into string data, or text. You will use one 

of these tools to create your functions. 

 

13) Add Format Into String to the VI 

a. Select Programming»String»Format Into String 

b. Click in the middle of the block diagram to place the VI 

14) Use Context Help to understand the VI 

a. Hover the cursor over the Format Into String VI 

b. Press <Ctrl-H> to open the Context Help and see what this VI does 

 



 

 

The <Ctrl-h> keys in keyboard shortcuts correspond to the (Mac OS) <Shift-Command-h> keys.  

 

 

Figure 5. Context Help 

 

c. Click on the link to detailed help from the Context Help for Format Into String 

d. Review the help information to get a sense of what the VI does 

 

You will format the numeric data into string data using the Format Into String VI. To do this, 

you will create a template for how to handle the numeric data. In the case of work, you will 

simply convert the number into text. 

 

15) Right-click the Format Into String VI and select Edit Format String from the context 

menu to create and edit the template 

a. Use the Edit Format String window to build the expression, “%.6f” 

 

 

Figure 6. Edit Format String window 

 

b. Click OK to close the Edit Format String window 

 

The Format Into String VI will now have a terminal for a numeric input (DBL in orange). It 

will also have a pink input for the format string. 

 

16) Use the Wiring tool to connect the output of Multiply to the numeric input of Format 

Into String 



 

 

17) Save your VI, <Ctrl-S> 

 

 

Figure 7. Work input to the Format Into String VI 

 

The output of the Format Into String VI is simply the amount of work as string data, i.e. text. 

This string can be used as an input for an evaluation VI to create an array of data that can in turn 

be plotted on a graph. If this sounds confusing, all we are doing is building a table of x and y 

values in order to graph. 

 

18) Add Eval y=f(x).vi to the block diagram 

a. Select Eval y=f(x).vi from Mathematics»Scripts & Formulas»1D & 2D 

Evaluation on the Functions palette 

 

  

Figure 8. 1D & 2D Evaluation palette 

 

b. Click on the block diagram to place the VI to the left of the XY Graphs 

19) Use Context Help, <Ctrl-H>, to understand the Eval y=f(x).vi 

20) Use the Wiring tool to connect the resulting string output of the Format Into String VI 

to the formula input of Eval y=f(x).vi 

21) Connect other inputs to Eval y=f(x).vi 

a. Right-click on the start terminal of the VI, select Create»Constant, and set the 

value of the constant to 0 



 

 

b. Right-click on the end terminal of the VI, select Create»Constant, and set the 

value of the constant to 10 

c. Right-click on the number of points terminal of the VI, select Create»Constant, 

and set the value of the constant to 20 

 

 

Figure 9. Evaluation VI added to block diagram 

 

The Eval y=f(x).vi evaluates the formula for a set of x-values between the start and end. The 

VI outputs both a set of x-values and y-values. These sets are limited by the use of 0 and 10 for 

the start and end values. (It is possible to capture the X Scale minimum and maximum and use 

those for start and end. To do so, requires the use of Property Nodes, an advanced topic left for 

another time.) 

 

The sets of values created by Eval y=f(x).vi are arrays. The XY Graph uses both of the arrays to 

graph the function. To connect the two arrays to the XY Graph, you will bundle them together 

in a cluster. 

 

A cluster is like an array in that it can hold multiple items of value. The two types differ in that a 

cluster can hold multiple data types, while an array holds multiple elements of a single data type. 

 

22) Bundle the x and y arrays into a cluster 

a. Select Programming»Cluster, Class, & Variant»Bundle and click on the block 

diagram to place the VI 

b. Connect the X values output of the Eval y=f(x).vi to the first element of Bundle 

c. Connect the Y values output of the Eval y=f(x).vi to the second element Bundle 

 

  

Figure 10. Bundle VI on the Cluster, Class, & Variant palette 

 



 

 

23) Wire the output of the Bundle VI to the XY Graph 

a. The XY Graph will change from brown to pink to denote its data type as a cluster 

of numeric arrays 

24) Save your VI, <Ctrl-S> 

 

 

Figure 11. Data wired to the Work graph 

 

Next, let’s see how the VI runs. 

 

25) Return to the front panel by selecting Window»Show Front Panel or pressing <Ctrl-E>  

26) Use the controls to enter values for Force and Distance 

27) Run the VI by pressing the Run button or by pressing <Ctrl-R> 

 

You can run the VI using the Run Continuously button as well. Running continuously will have 

the code in the block diagram executed over and over again. To stop the execution, use the 

Abort Execution button. 

 

 

Figure 12. A graph of work displayed 

 

Are you surprised by the graph? The amount of work done does not depend on how long the 

work takes. Therefore, the graph will be a horizontal line. Work is the same whether it takes 1 

second or 10 seconds. 

 



 

 

Create a Graph for Work Done over Time 

 

To graph power, you will follow very similar steps to those you took to graph work. In creating 

the formula, you simply need to remember 
t

W
P . 

 

28) Return to the block diagram, Window»Show Block Diagram or press <Ctrl-E> 

29) Add Format Into String to the VI 

a. Select Programming»String»Format Into String 

b. Click below the other Format Into String to place the VI 

30) Right-click the Format Into String VI and select Edit Format String 

a. Use the Edit Format String window to build the expression, “%.6f/t” 

b. Click OK to close the Edit Format String window 

 

As before, the Format Into String VI will now have a terminal for a numeric input (DBL in 

orange). It will also have a pink input for the format string. 

 

31) Use the Wiring tool to connect the output of Multiply to the numeric input of the new 

Format Into String 
a. Hover the cursor over the wire between the Multiply VI and the previous Format 

Into String VI until the Wiring tool appears 

b. Connect the wire to the input 1 terminal of the new Format Into String 

 

 

Figure 13. Work input to the second Format Into String VI 

 

The output of the Format Into String VI is a string with the amount of work, a number, 

followed by “/t”. This string will get evaluated for different values of t using the Eval 

y=f(x).vi. LabVIEW will use the t in place of an x as the independent variable. 

 

32) Add another Eval y=f(x).vi to the block diagram 

33) Use the Wiring tool to connect the resulting string output of the Format Into String VI 

to the formula input of Eval y=f(x).vi 

34) Connect other inputs to Eval y=f(x).vi 

a. Right-click on the start terminal, select Create»Constant, and set to 0 

b. Right-click on the end terminal, select Create»Constant, and set to 10 



 

 

c. Right-click on the number of points terminal, select Create»Constant, and set 

to 20 

35) Bundle the x and y arrays from Eval y=f(x).vi into a cluster 

a. Select Programming»Cluster, Class, & Variant»Bundle 

b. Connect the X values to the first element of the Bundle VI 

c. Connect the Y values to the second element of the Bundle VI 

36) Wire the output of the Bundle VI to the Power graph 

37) Save your VI, <Ctrl-S> 

 

 

Figure 14. Data connected to Power graph 

 

Next, let’s see how the VI runs. 

 

38) Return to the front panel by selecting Window»Show Front Panel or pressing <Ctrl-E>  

39) Use the controls to enter values for Force and Distance 

40) Run the VI by pressing the Run button or by pressing <Ctrl-R> 

 

 

Figure 15. Work and Power displayed in front panel 

 

The WorkPower VI is complete. Of course, more customization is possible. You could resize the 

graph or the front panel itself. Also, right-click on any of the controls or indicators to see what 

else could be made visible or what properties could be changed. Many display options are 

configurable. 


